
 

 

 

 

 

A Simple Productivity Booster may save the day 

 

21  

UNDERGROUND EXCEL
®

 TIPS  

VOL 1  

b y John Franco  

Founder  www.Excel -Spreadsheet -Authors.com  

Tips are A lways W elcome  

http://www.excel-spreadsheet-authors.com/


21 Underground Excel ®  Tips  Volume 1 ©  

www.Excel -Spreadsheet -Authors.com   2  | P a g e  

 

 

 

 

 

 

 

 

 

 

Share/E mail /Print this Book for free . Pass it along  as long as you make no 

changes to  its content or  digital format.  

If you want to sell this book or use it f or commercial purposes,  please 

Contact me  

 

 

© 2009 by Excel -Spreadsheet -Authors.com

http://www.excel-spreadsheet-authors.com/contact-me.html


21 Underground Excel ®  Tips  Volume 1 ©  

www.Excel -Spreadsheet -Authors.com   3  | P a g e  

 

 

TOC  

TOC ................................ ................................ ..............................  3  

Introduction  ................................ ................................ ...................  5  

How much does this eBook cost to you?  ................................ .............  6  

1.  Jump to a Target Cell in Two Ways (without Manually Shifting 

Sheets /without Scrolling)  ................................ ................................ .  7  

2.  Get Oriented about Meaning of Named Ranges as You Write Formulas 

(Excel 2007)  ................................ ................................ .................  10  

3.  Find/Replace/Select  Similar Format Cells  ................................ .....  12  

4.  Sum Numbers -Stored -as-Texts  ................................ ..................  14  

5.  Copy Formulas Down Automatically in Calculated Columns (Excel 

2007 )  ................................ ................................ ..........................  15  

6.  Convert a Number/Date -Stored -as-Text to Number/Date before 

LOOKUP ................................ ................................ .......................  17  

7.  Avoid Array Formulas by Using Helper Columns  ............................  18  

8.  Use Hidden Constants in Calculated Columns  ...............................  20  

9.  Add Comments Inside Formulas  ................................ .................  22  

10.  Clean Text before LOOKUP  ................................ ......................  23  

11.  Use Named Ranges for Printing, Formatting and More  .................  24  

12.  Get Rid of Mes sy Columns before Loading a Csv File  ...................  26  

13.  Filter by the Selected Cell  ................................ .......................  28  

14.  Highlight Duplicates Cells in a Flash (Excel 2007 )  .......................  30  

15.  Deselect Hidden Cells  ................................ .............................  32  

16.  Build A Logical Formula without Logical Functions  .......................  34  

17.  Highlight Unique Cells in a Flash (Excel 2007)  ............................  35  

18.  Convert Number -Stored -as-Texts To Numbers  ...........................  37  



21 Underground Excel ®  Tips  Volume 1 ©  

www.Excel -Spreadsheet -Authors.com   4  | P a g e  

 

19.  Sum/Count/Average only Visible Rows with SUBTOTAL Function  ...  38  

20.  Check VLOOKUP Formula for #NA Error without Slowing Down 

Computations (Excel 2007)  ................................ .............................  40  

21.  Debugging shortcut  ................................ ................................  41  

What Readers Say about Excel -Spreadsheet -Authors.comé .................  42  

Excel Resources  ................................ ................................ ............  44  

About John  ................................ ................................ ...................  45  

 



21 Underground Excel ®  Tips  Volume 1 ©  

www.Excel -Spreadsheet -Authors.com   5  | P a g e  

 

Introduction  

What is the power behind  Tips? 

A tip does not require significant eff ort 

to learn  and give you a boost in your 

productivity in some way.  

Additionally , an  Excel T ip is perceived  

to be the qu ickest/unique way to do 

a thing .   

Here you have a list of some pros é 

¶ Save time by performing  a given 

action  in less time  (less 

keystroke s, less manual work, etc)  

¶ Help you c onnect gaps that open doors to more knowledge  

¶ Grow your enthusiast for Excel so you keep more productive (action 

causes inspiration)  

¶ Reuse  the knowledge you already possess  in different ways  

¶ Learn a Tip in a flash and ge t results immediately  in your work  

¶ Get  instant reward  because its  instant application  nature  

¶ Perform an action you didnôt imagine possible 

¶ Reuse Tips  along time  in all circumstances  

Tips are workload relievers ;  for example,  compare  dragging the mouse 

sligh tly  to resize column width with resizing width immediately by double 

click ing  on the border of the column header . Even better ;  compare doing 

it  individually to doing it massively by selecting and double clicking 

multiple columns.  

This eBook is a collection  of 21 Tips not so exploited  but very useful.  

Apply them and f eel enthusiastic each time your productivity is boosted.  

If you are eager for more try these 101 Addictive Tips . 

 

John Franco  

July 15, 2009  

"Hi John... you have 
very good content 

here.  

I am subscribing to 

your blog for my daily reading 

list."  

 

Chandoo , Pointy Haired Dilbert   

Chandoo.org  

See more  testimonials  

http://29c0bbtby6avdy91wl66wpfu1e.hop.clickbank.net/?tid=EXCELADDICT
http://www.chandoo.org/
http://www.excel-spreadsheet-authors.com/testimonials.html
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How much does this eBook cost to you?  

Zero , it is absolutely free.  

How can you pay it forward? Help me spreading the word  

 

Print  this eBook  and distribute  it to colleagues  

Email  this eBook  to 5 friends or colleagues  
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1.  Jump  to a Target Cell in T wo Ways (w ithout 

Manually Shifting Sheets /without  Scroll ing ) 

Imagine you are working between two sheets , here is the situation :  

Youé 

¶ Shift between worksheet s ( you may need to use the horizontal 

arrows to move across sheet tabs)  

¶ Scroll (ve rtically, horizontally) to the desired cell  

¶ Check something, write a Formula  or edit the content of the cell  

¶ Return to previous cell  in the previous sheet . All would be ok but 

the screen is not where you want , you need to do a finding -cell 

work each time y ou move intuitively across your spreadsheet  

Imagine an Excel Tip that allow s you to j ump to the target cell instead of 

scrolling and shifting sheets . No, you donôt need to use Named Ranges for 

each set of cells worth visiting.  

Hereôs how to navigate betwee n sheets and books very easily é 

Method 1: Jump to target cell with ñGo toò dialog (F5): 

How toé 

1.  Select the cell at which you want to return , for example A1  

2.  Press F5  to launch the ñGo toò dialog 

3.  Type the desired cell reference in ñReference:ò box to j ump to 

it;  for example B35  

4.  You have mark ed A1 in the ñGo toò pane for the curren t  

session  

5.  Press F5 from anywhere and double click on the desired cell  

that is already listed on the pane  
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Step 2, 3  

 

Step 5  
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Method 2: Jump to target cell with ñWatch Window ò dialog:  

ñWatch windowò allows you to debug Formulas ; its main use is to see the 

impact of dependent cells  on  the watched ones . You can use it also to 

navigate between sheets and books, hereôs howé 

How toé 

1.  Launch the ñWatch windowò dialog. Excel 2007 user s: g o to 

Formulas>Formula Auditing>Watch Window . Excel 2003 

users: go to Tools>Formula Auditing>Show Watch Window  

2.  Place at the target  cell  you want to mark  

3.  Press ñAdd watchò 

4.  Jump to any cell from the watch window by simply double 

clicking on it  (in the ñWatch W indow ò pane)  

 

 

 

Amaze yourself ... and others with Excel Tips  

Get a career boost by nurturing your Excel Skills. Learn 

how to write smarter Formulas , how to bui ld simpler 

spreadsheets. Gain  knowledge and techniques you can 

implement immediately.  

Subscribe to monthly free Holistic Spreadsheet 

Newsletter  

http://29c0bbtby6avdy91wl66wpfu1e.hop.clickbank.net/?tid=EXCELADDICT
http://www.excel-spreadsheet-authors.com/microsoft-excel-newsletter.html
http://www.excel-spreadsheet-authors.com/microsoft-excel-newsletter.html
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2.  Get Oriented about M eaning of Named Ranges 

as You Write Formulas  (Excel 2007)  

Constants and names (N amed Ranges) had been  subjectively defined  in 

previous versions of Excel ;  now you can set  the meaning explicitly and 

read this description as you write Formulas.  

How do you do this? It is very easy: define the name and introduce a 

description . Formula Autocomplete will show the message at the cell or 

Formula  bar  while you write . 

Hereôs howé 

First you need to define a name with a description, proceed this wayé 

How toé 

1.  Go to F ormu las> Defined names> Define name  

2.  Enter  the named range ñName:ò 

3.  Set the ñScope:ò 

4.  Write  the ñComment ò 

5.  Specify t he reference or value in the ñRefers to: ò box  

6.  Ok 
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To get the description as you write you just need to start writing a 

Formula  at any cell or  at the Formula  bar,  Formula Autocomplete  will 

assist you .  

See graphic below é 

 

 

Eliminate many hours of wasted time and frustration with 101 Excel Tips  

 

Get a career boost by nurturing your Excel Skills. Learn 

how to write smarter Formulas , how to bui ld simpler 

spreadsheets. Gain  knowledge and techniques you can 

implement immediately.  

Subscribe to monthly free Holistic Spreadsheet 
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3.  Find /Replace /Select Similar Format Cells  

Sooner or later you need to select similar - format cells  for  editing /analysis  

purposes .  

Hereôs how to do ité 

How toé 

1.  Press CTRL + F  

2.  Press Options>>  

3.  Click the arrow to the right of ñFormatò button (located at the 

right of the ñFind what:ò text box) 

4.  Select ñChoose Format From Cellò (you can do it manually by 

using ñFormatò option instead) 

5.  Select the cell with the target format  to select. The format is 

prev iewed at the right of ñFind what:ò text box 

6.  Press ñFind All ò. All the cells with the selected format are 

shown in the pane  

7.  Pick cells individually or press CTRL t o select more than one  to 

do the require d action : replace , find, etc  

Step 4  

 

 

Step 5, 6  
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I mportant notice  

Donôt forget to select ñclear F ind Formatò to be able to use find/replace 

command the next time.  

Amaze yourself ... and others with Excel Tips  

 

Help me sp reading the word  

Print  this eBook  and distribute  it to colleagues  

Email  this eBook  to 5 friends or colleagues  
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4.  Sum  Numbers -Stored -as -Texts  

SUM fu nction does not convert numbers -stored -as- texts to numbers . See 

graphic belowé 

¶ A3 is 1 stored as text  

¶ The  Formula  in A4 is =SUM(A 1: A3)  

¶ The result is 2 (A3 was not considered)  

 

Now, s ee the result of the Formula  C4, it is correct. How do you do it?  

Hereôs howé 

How toé 

1.  Write the Formula  in C4: = F1+F2+F3 instead of 

=SUM(F1:F3)  

 

Avoid mistakes  

Donôt use long Formulas  like: =A1+A2+A3+A4+é Use this tip for check 

SUM Formulas  only . 

Read:  Excel SUM ï Problems to Be Aware of When You Use this Common 

Function  

 

 

Get a career boost by nurturing your Excel Skills. Learn 
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5.  Copy Formulas Down Automatically in 

Calculated Columns (Excel 2007)  

When do you use Formulas  in tables?  

¶ When you employ  helper columns and need consistency and 

completeness of the Formula  in the entire c olumn  

¶ When you have a calculated column in general  

Copying Formulas  down in a table presents two main problems:  

¶ It is tedious to drag the Formula , especially in tables with 

hundreds / thousands of rows  (you can double click fill handle to 

automatically fill Formulas  down  but they stop at blanks  or you may 

forget to do it )  

¶ It is difficult to remember you need to copy a modified Formula  to 

the entire column  

A calculated column with an undetected orphan Formula  in the 

middle  is t he wo rst thing . 

Fortunately, Exce l 2007 offer s a Formula auto filling  option . Proceed this 

wayé 

How toé 

1.  Activate options Formula  auto fill . Go to Office Button>Excel 

Options>Proofing>Autocorrect Options>Autoformat As You 

Type >Fill Formulas in tables to create calculated columns  (this 

opt ion is activated by default)  

2.  Convert the range into a table  (CTRL+T)  

3.  Write the Formula  in the calculated column  

4.  Enter  (Excel 2007  automatically fill up/down the Formula to 

the entire column)  

 

Eliminate many hours of wasted time and frustration with 101 Excel Tips  
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6.  Convert a Number /Date -Stored -as -Text to 

Number /Date  before LOOKUP  

Imagine you want to look up  the cell  A2 in any given table array ;  the cell 

contains a number /date  in form of text . 

Avoid imminent # N/ A error by convert ing  the cell  before lookup ; do it this 

way é 

How toé 

1.  Write VLOO KUP Formula  

2.  Add 0 to the lookup_value argument this way: 

=VLOOKUP(A2+0  

3.  Complete the Formula : 

=VLOOKUP(A2+0,Haystack!$A$2:$C$12,2,0)  

 

Catapult your skills and productivit y with Excel Tips  
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7.  Avoid Array Formulas by Using  Helper C olumns  

Array Formulas are a big deal  but you may not be  proficient with them. If 

you want to keep away until you learn, use a  workaround called Helper 

Columns.  

What a Helper Column is?  

It is an additional column that serves as a criteria column, you can 

evaluate as many conditions as you want an d reduce them to a single 

value.  

You can use :  

¶ CONCATENATE function  to combine  tw o or more columns into a 

single one, for example: City and Name into "ChicagoSusan Wilson "  

¶ Logical Functions :  IF, AND, OR  to reduce criteria of multiple 

columns to TRUE/FALSE  or any other single value, for example: 

=AND(A2="Susan Wilson",C2>1000,C2<=10000)  returns 

TRUE/FALSE 

Well, w here do you use Array Formulas most? You use AF w hen you need 

to create multiple versions of SUMIF, COUNTIF, and VLOOKUP . These 

functions have  something in  common, the y cannot evaluate conditions 

like: between, and, or, etc . 

See their syntax es below and recognize the unique -criteria -arguments  

(bold ones) that will contain  a value that represents multiple criteria, for 

example: ñChicagoSusan Wilsonò, TRUE, FALSE, etc.  

¶ SUMIF( range ,criteria ,sum_range)  

¶ COUNTIF(range, criteria )  

¶ VLOOKUP( lookup_value ,table_array,col_index_num,range_lookup)  

Hopefully Excel 2007 added SUMIFS, COUNTIS functions that eradicate 

this old problem.  

But Array Formulas are still needed for example to create  VLOOKUP 

multiple, VLOOKUP case sensitive, etc.  

Hereôs how to set a HC  for multiple VLOOKUP é 



21 Underground Excel ®  Tips  Volume 1 ©  

www.Excel -Spreadsheet -Authors.com   19  | P a g e  

 

How toé 

At the Backend  

1.  Add a column to the left  

2.  Write  a Formula  that evaluates  conditions in two or more 

columns. Use : CONCATENATE , & , IF, AND, OR , a comb ination 

of them . For this case:  =CONCATENATE(B2,C2)  

At the Fronten d  

3.  The Formula  is done : =VLOOKUP(CONCATENATE( ñSusan 

Wilsonò,1526 ),Heystack!$A$2:$F$12,6,0)  you can use 

" Susan  Wilson "&"1526"  for the lookup_value  too  

 

Step 1, 2  
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8.  Use Hidden Co nstants in Calculated Columns  

Avoid columns with repeated quantities ;  for example, the % column 

below is obtained from dividing the Rank by 1,000,000 ( Number of sites ). 

Notice that you have not created a Total pages column  with 1 million 

repeated .  

 

How d o you do it?  

How toé 

1.  Go to Formulas>Defined names>Define name  

2.  Specify the Name (without spaces)  

3.  Set the Scope: Workbook or on a Sheet basis  

4.  Specify the value of the constant in  ñRefers to:ò 

5.  Ok 
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After that, insert the constant by using Paste name dial og ( F3)  or through 

Formula Autocomplete.  

Read the article: Excel Formulas -  How to Store Constants in a Central 

Location with Excel Names  

 

Catapult your skills and productivity with Excel Tips  
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9.  Add Comments Inside  Formulas  

This workaround consists in adding a note to a Formula  (essentially 

adding 0 ) this way: =FORMULA + N(ñNotes hereò). 

N function converts any item to its value, for example:  

¶ =N(TRUE) is equal to 1  

¶ =N(ñAny textò) is equal to 0 

This method could be better tha n Cell C omments because the notes  

rema in  inside  the Formula  and can  be seen while debugging .  

How toé 

1.  Go to the end of any given Formula . For example: 

=SUBTOTAL(109,A1:A13)  

2.  Sum the note: + N("Quarter 4 not included") . Essentially you 

are adding 0 to a Formula  

3.  Enter. Your Formula  will be somet hing like this: 

=SUBTOTAL(109,A1:A13)+N("Quarter 4 not included")  

 

Amaze yourself ... and others with Excel  Tips  
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10.  Clean Text before LOOKUP  

Texts are the most common lookup data in Excel, sometimes you receive 

a #N/A error due to non -matching values; use this tip when the problem 

is at the frontend.  

How toé 

1.  Write the VLOOKUP Formula  and specify the lookup_value  

2.  Delete leading/ trailing / inter -word spaces with TRIM function : 

TRIM(A 2) . Clean remaining non -printing characters with 

CLEAN function. CLEAN(TRIM(A 2))  

3.  Complete the Formula : 

=VLOOKUP( CLEAN(TRIM(A2)), G5:H28,4,0).  

4.  Enter  

 

 

Tip compiled from: 29 Excel Formula Tips for all Occasions [and proof that 

PHD readers truly rock]  
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11.  Use Named Ranges for P rinting , 

Format t ing  and M ore  

Named ranges elicit Formulas but you can exploit this feature to boost 

your productivity  when formatting , printing  and other relevant tasks . 

Having a quick way to do these  tasks  help s a lot.  You cané 

¶ Set print ing  areas  (you can name irregular arrays)  

¶ Apply format . The fact is that you apply format to well -known areas 

of your sheet, for exampl e: headings, data, etc.  

¶ Calculate subtotals (SUM, COUNT, AVERAGE, MAX, MIN, etc) about 

selected data with an eyeball at the status bar  

¶ And moreé 

The quickest way  to define names is this wayé 

How toé 

1.  Select the range to name  

2.  Go to Name box at the left  of th e Formula Bar  

3.  Specify the Name (without spaces)  

4.  Enter  

 

Now use names ;  for example , to  print é 

How toé 

1.  Select cells by going to Name Box and choose the name from 

the list  

2.  Go to Page Layout>Print Area >Set P rint Area  

3.  Click  
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12.  Get  Rid of Messy Columns before Loading 

a Csv File   

Third party software reports usually come with unnecessary data for your 

analysis .  

Choose the needed field s only  if you are in control of the exporting 

process ; on the other hand,  if you have a txt file already in your hands, 

hereôs a way to diminish the amount of post - importing -manual -worké 

How toé 

1.  Use Text to columns wizard.  For Excel 2003 users go to 

Data>T ext to columns. For Excel 2007 users go to Data>Data 

Tools>Text to columns  

2.  Split your column with any of the two methods  (step 1/3)  

ñDelimitedò or ñFixed widthò 

3.  Select the columns you want to skip (step 3/3)  

4.  Select ñDo not import column (skip)ò option (st ep 3/3 )  

5.  Click Finish  
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13.  Filter by t he Selected C ell  

Excel 2007 added  the feature to filter table fields by the selected cell.  

What does this mean?  

Focus on analyzing data instead of defining filter criteria each time . 

This quick filter method is ideal for selecting  categories, for 

example: cities, products, subjects, suppliers , etc.  

You can filter by :  

¶ Cell's value  

¶ Cell's color  

¶ Cellôs font color 

¶ Cell's icon  

 

How toé 

1.  Select the cell on which you want to apply the filter  or right 

click directly on it  

2.  Go to: Filter>Filter by Selected Cellôs value  

3.  Click  
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14.  Hig hlight Duplicates Cells in a Flash (Excel 

2007)  

The ñRemove Duplicates ò command does not offer a step by step wizard 

so you can decide which data to delete.  

Decide yourself which duplicates need to be deleted or which need special 

treatment.  It is very eas y 

How toé 

1.  Go to Home>Styles>Conditional formatting> Highlight  Cells 

Rules>Duplicate values  

2.  Choose ñDuplicate ò and Define the format: predefined or 

custom  

3.  Ok 

 

Step 1  
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Step 2  

 

Done  
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15.  Deselect H idden Cells  

Pasting unwanted hidden cells is a well -known problem in Excel. You 

usually co py 4 rows and paste 6 rows because 2 were hidden.  

This does not occur when rows are hidden as a result of Filter command. 

If your case is the first outline above, here is a solutioné 

How toé 

1.  Select the range that contains hidden rows/columns  

2.  Launch ñGo toò dialog (F5) 

3.  Press ñSpecialò 

4.  Choose ñVisible cells onlyò 

5.  Ok 

 

You can now:  

¶ Copy and paste  cells  

¶ Get subtotals about the visible cells at the S tatus Bar  

Step 1  
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Step 4  
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16.  Build A Logical Formula w ithout Logical 

Functions  

This is a  handy way to evaluate simple conditions : equals to, d oes not 

equal to, less than, greater than, etc . you can use this tip in :  

¶ Helper columns  

¶ Ad Hoc  calculations  (take care of ad hoc Formulas , read: Excel 

Formula -  7 Critical Reasons to Avoid Hard Coded Numbers )  

¶ Formulas  

¶ And moreé 

How toé 

1.  Press = in a any given cell  

2.  Use logical operators to evaluate the desired condition: =, <, 

>, <=, >= . You can compare cell references  (=A1=B1) , hard 

coded values  (=A1>1000) , resul t of other Formulas  

(=VLOOKUP () =ñSusanò) 

3.  Enter . The Formula  will retrieve TRUE or FALSE  

 

Example 1 ï using cell references  

 

Example 2 ï using functions  

=VLOOKUP(F2,$L$2:$M$3,2,0)>G2  
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